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4. How to use Makelangelo Software 7.32+

Instructions for running the software for the first time, preparing the drawing and sending it to your
plotter robot.

Written By: Dan Royer
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INTRODUCTION

Instructions for running the software for the first time, preparing the drawing and sending it to your
plotter robot. There is more than one way to Prepare art and more than one way to Run the robot.
It's OK to skip some steps.
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Step 1 — Welcome!

File Settings Generate art Tools View Makelangelo Help

= @ This guide will show you how to use
B Makelangelo Software 7.32.0+

Step 2 — Install Java (if necessary)

e Visit hitps://www.oracle.com/ca-
en/java/techno...

Products Industries Resources Customers Partners Developers Events Company Q @ View Accounts

@ Choose your OS

Javadownloads  Toolsand re

Java SE D K 2 di

Click the link of your choice to
download the Java installer app.

Thank you for dewnloading this release of the Java™ Platform, Standard Edition Development Kit {JDK™). The JDK is a development enviranment for building applic
components using the Java programming language.

The IDK includec tnnle for dovslanine and testing programs written in the Java programming language and running on the Java platform.

Linux mac0S  Windows

e Run the installer app when the
x64 Compressed Archive 7913 MB hitps://download.oracle.com/java,/19/latest/jdk-19_windows-x64_bin zip  sha256) d OW n IO ad i S d O n e .

%64 Installer 15891 MB hittps://downloa

om/java/19/latest/jdk-19_wi

vs-x6d_bin.exe ( sha25e)

x64 MS! Installer 15776 MB hitps://download.oracle.com/java/19/latest/jdk-19_windows-x64_bin.msi ( sha256)
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Step 3 — Install Makelangelo Software

T T e =
End-User License Agreement %
Welcome to the Makelangelo Setup S

Please read the folowing lcanse agreement carafully

Wizard
~
The Setup Wizard vl instal Makelangelo on your Computer.
Clck Next to continue or Cancel to exit the Setup Wizard. GNU GENERAL PUBLIC LICENSE
Version 2, June 1991
Copyright (C) 1989, 1991 Free Seftware Foundatien, Inc.
<http:/fisf.org/> 51 Franklin Street, Fifth Floor, Boston, MA 021101301
USA Everyone is permitted to copy and distribute verbatim copies of
this license document, but changing it is not allowed.
Preamble L
[t accept the terms in the License Agreement
cance print Bk Cence
3 Mokelongelo Setup = X |48 Makelangele Setup & X
Destination Folder ~ < -
Click Next to instal to the default folder or dick Change to dhoose another. l-;-* Ready o Instal Makelngelo P
Install Makelangels to:
Click Install tn begin the instalation. Click Back to review or change any of your

installation settings. Click Cancel to exit the wizard,

[c:\Program Fies\akelangela\

Change...

sl Cancel

Step 4 — Windows only: Install RUMBA Drivers

re is litle support from Makerbase so there needs 1o be a page adressing setup and use of the RUMBA+

JMEA board RUMBA PCE hole RUMBA schomatic RUMBA schemalic EXP3 RUMBA PCE all layer
spacing dimensians connector
ifety Tip
Caution

Once you start putting electricity into your RepRap - even at just 12 volts - you have to take basic, common sense precautions to avoid fires.
Justin case these fail, test your worksnop smoke detectors?. Got no smoke detector? Get onet

UMBA USB Driver for Windows

NEW : Easy driver setup for Windows B/T/Vista/XP 32 and 64 bit
File:'RRD RUMBA TAURING C zip

CLASSIC: (can cause problems with Windows 8 and Vista/T §4bit, use the easy method from above instead)
When you attach RUMBA for the first time 10 a Windows computer you might need 10 provide a driver (INF file)
File:RRD-RUMBA USB DRIVER Zip

ratures

compact size: 135mm x 75mm

fully integrated all in one solution
« Arduino 2560-R3 compatible (works with Sprinter, Repetier-Firmware, Marlin out of the box)
= ATmega16U2 (with enhanced firmware) for high speed USE serial connextion (up to 2MBit)
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e Makelangelo Software for Windows,
Mac, and Linux can be downloaded
from two places:

e The official stable release

e The unstable Nightly Build

e After downloading the application,
run it and follow the steps therein to
install Makelangelo Software.

e Makelangelo robot uses the RUMBA
control board in the robot. To talk to
your computer you may need to
install a driver.

e If you are on Windows, please make
sure you already have the drivers for
the RUMBA board from
https://reprap.org/wiki/RUMBA#RUM
BA_USB ...
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Step 5 — Run Makelangelo Software

e Double click on the app in your PC.

e A dialog will ask you to choose your
preferred language.
e Don't see your favorite? Help us
help you!
https://crowdin.com/project/margin

allycl...

Makelangelo
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Step 6 — OSX "file damaged" message

) e Open the System Preferences by
2 Selecting Apple Menu > System
Preferences

@ Click Security & Privacy under the
“Makelangelo” is damaged and

can't be opened. You should General tab.
eject the disk image.

@ Click the icon labeled Click the lock

Makelangelo to make changes in the bottom-left
objects.githubusercontent.com corner.
Eieck Bisk Imago e Enter your username and password

) Makelangelo » ¢) Makelangell .
d - into the prompt that appears and

click Unlock. (If you have no

password, this can be left blank).

@ Under the section labeled Allow
applications downloaded from:,
select the option "Anywhere". On the
prompt that appears, click "Allow
From Anywhere."

o If that doesn't work, open a console
and entering the command sudo
xattr -cr
/Applications/Makelangelo.app

@ Thisis due to this bug
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Step 7 — OSX security issue

Security & Privacy

General  Filevault  Firewall  Privacy

A login password has been set for this user | Change Password...

+ Require password 5 seconds £ after sleep or screen saver begins

\r apps downloaded from: l
?@!;“

"Example-App” was blocked from use because it is not from an
identified developer.

Open Anyway

|

v

Q Click the lock to make changes

Step 8 — Familiarize yourself with the controls

File Settings Generateart Teols View Makelangelo Help

va \
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e OSX may block the Makelangelo
Software because it is from an
"unidentified developer".

Click the apple icon in the top left,
then System Preferences, then
Security & Privacy. Having just tried
to run Makelangelo-software* jar, it
should appear in this message.

@ You might need to unlock to allow
security changes.

Click Open Anyways.

(@) Your security for this version of the
app should now be set forever. Next
time the app updates you might
need to do this again.

o Inthe main window you can drag to
pan and scroll the mouse wheel to
zoom the what you see is what you
get preview.

e The File menu is where you can
load images including SVG, DXF,
Scratch 3 programs, and bitmaps
like photographs or your favorite
meme.
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The Settings menu controls the
paper, pen, and plotter preview. The
default paper size is A2.

The Generate Art menu creates
different styles of algorithmic
procedural art. Try it and see!

The Tools menu will change your art
after being loaded/created. Scale,
flip, and optimize for drawing tools
like Simplify and Reorder.

® The View menu can move the
camera with zoom to fit but also
show travel moves and advanced
features like render style which
reveals how the robot thinks about
the art being drawn.

@ The Makelangelo menu controls the
cosmetic preview of the robot, the
drawing estimate time, robot
commands save GCODE to SD
card/disk, and finally Open
Controls to talk live to a connected
robot.

@ The Help menu has links for our
Discord forums, a check for
updates features, and more.
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Step 9 — Paper Settings

File Seltings Generateart Tocls View Makelangelo Help

@ Paper size will automatically change
the width and height based on pre
set values.

o Shift will move the paper inside the
printer.

« Rotatewill turn the paper.
Landscape will instantly switch
between 0 and 90 degrees.

® Margin on your paper will prevent
the pen from going off the edge.

® Paper coloris great for experiments
with silver/gold pens on colored

paper.

Step 10 — Plotter settings

File Settings Generateat Tools View Makelangelo Help

® Machine width and Machine height
control the size of the maximum
allowed drawing area, aka the work
area.

o If you are making a DIY plotter the
Stepper, Timing belt, and Servo
length (meters) will help you plan
your design.
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Diameter controls the size of the pen
tip on the paper. This is used by
nearly every algorithm. The default
size of a Sharpie tip is 0.8mm

speed and acceleration affect
horizontal and vertical movements,
only. Experiment and share your
results in the forums.

@ bigger Lift delay makes the pen rise
and fall from the paper more slowly,
which helps prevent bouncing. Up
and Down are angle values. The
default is 90 for up and 40 for down.
Up color can only be seen when
View> Show travel moves is on.

@ The remaining settings are
advanced parameters used for time
estimates and should only be
changed by expert users.
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Step 11 — Draw from a photo

File Settings Generateart Tools View Makelangele Help

Help
New Ctrl=N

Openfile..  Ctl+0 b- |' : : C g
0 K
Reopen last file . 1r"- Rl — = ite

Save File... Ctrl+$ "

d file preview X
Preferences  Alt=P

pen flle... C:\Users\aggra\Documents\drawbot artibil-murray.jog
Update firmuware
ConvertimagePanel

Fil | Fitimage on paper v

Quit Ctrl+Q

@ Click File > Open File... and select your PNG, BMP, JPG, GIF, or PIO image file.
The Style list lets you choose one of several image-to-line converters.

Most styles will have additional settings to tweak.

@ When you are satisfied, close the dialog and proceed to Makelangelo > Save to SD card or
Makelangelo > Open Controls. (we recommend the SD card)
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Step 12 — Load a vector file

File Selings Generate ait Tools View Makelangelo Help

@ Click Open File... and select your
DXF, SVG, or GCODE file. The
image will be automatically scaled to
fill the paper margins.

@ When you are satisfied, close the
dialog and proceed to Makelangelo
> Save to SD card or Makelangelo >
Open Controls. (we recommend the
SD card)
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Step 13 — Load a Scratch file

File Seltings Generateait Tools View Mekelangelo Help

New Ctrl+N

Reopen last file
Save File... Ctrl+5

Coda
Preferences. Alt+P

Update firmuware

Quit Ctrl-Q

jojeieiojoiniojeie s

£
§

RUEH 66 GOBH &8
ol:l le «
Q

Build your Scratch drawing at https://scratch.mit.edu/.

o Click File > Save to your computer.
o Click Open File... and select your SB2 or SB3 file. The resulting program will be automatically
scaled to fill the paper margins.

@ When you are satisfied, close the dialog and proceed to Makelangelo > Save to SD card or
Makelangelo > Open Controls. (we recommend the SD card)

This document was generated on 2023-11-30 10:48:37 PM (MST).
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Step 14 — Generate art

File Seltings Generateart Tocls View Makelangelo Help
—_

o Click Generate art and select a
style. Here the user has chosen
Maze.

o Many styles have sub options that
can be adjusted. Experiment!

@ When you are satisfied, close the
dialog and proceed to Makelangelo
> Save to SD card or Makelangelo >
Open Controls. (we recommend the
SD card)

o Simplify looks for short lines that - added together - would equal one longer line and makes the
swap.

o Reorder rearranges the existing lines to reduce the total amount of travel moves. Try it when
"show travel moves" is turned on!
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Step 16 — Draw from SD card (recommended)

File Settings Generateart Tools View | Makelangele Help

Robet style

Estimate time Ctrl«E

Save Geode to file/SD Cirl~G h

Open Controls Ctrd+T

e Putthe SD card in the computer and click Makelangelo > save to file/SD card. Follow the steps
and save the file to the SD card.

Eject the SD card and plug it into the robot on the left side of the LCD panel.

o Click the dial, scroll down to print from media, click again, scroll to the file, and click one more
time. Follow the prompts on the LCD panel.

Don't forget to Find home on the robot before starting your drawing! Find home can also be done
through the LCD menu.
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Step 17 — Run the robot connected

‘‘‘‘‘‘

e Plug a USB cable from the robot into your PC running Makelangelo Software.
@ Click Makelangelo > Open Controls.
Choose a port and click Makelangelo > Open Controls.

@ If you have no port then your robot is not on, not connected, or your operating system has a
security issue.

click Find home. Your robot should move the pen head down and the counter weights up until the
weights touch each switch twice.

Click Draw. You will be reminded to setup your pen in the pen head. Now is a good time to take
the cap off the pen!

e The same warning appears on the LCD panel. You much click the blue dial by pressing in, once.
The machine will begin to draw.

e If something is going wrong with your drawing, you can press the reset button on the LCD panel or
EMERGENCY STOP in the app.
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Step 18 — Windows firewall issue

Al

% o &

Detss.

e W&o

cccccc

This error often looks like Windows crashes when you click Connect.
@ In Windows press Windows Key + R to open Run.
@ Type control and press OK'to open Control Panel.

@ Click on System and Security, then Windows Defender Firewall, then Allow an app or feature
through Windows Defender Firewall

e In the allowed app window, scroll through all the apps. Locate the Makelangelo. If it does not
appear, locate Java(TM) Platform SE binary.

If it is unchecked, the app is blocked on the Firewall. Check the app and click OK.
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Step 19 — Show off your creation

e Take a picture.

@ imakerobots

eeo—— .| @ Postit on social media. Some great
oot s s s tags are #plottertwitter, #plotter, and
e @imakerobots so we can reshare it
Ia::_l:i:_:vrd I'm impressed!
horor_v_od This is simple explanation
of "Theory of relativity™!

scoolfpy OK | have to build one &
jojojojojojoT6 Awesome! You happen

to have some building instructions,
§TLs, .. @

revenge_follower Supperb.canu
help me in studying this? @ @ ;i
jakobhuldahl Wow v v

Q& A

". Liked by heikekapp and 4,026 others

4 e e e
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